FC2ブログ

上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

OpenWRTのネットワーク設定を変更する(FON2100E)


有線LANと無線LANのブリッジ解除
openWRT(8.09)はインストールしたフォルトの状態では有線LAN(LAN側)と無線LANのインターフェースがbr-lanというインターフェースとしてブリッジされている。/etc/config/networkを下記のように変更することで有線と無線を別々のインターフェースとして構成できる。


# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
# option type bridge  ←コメントにするだけ
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0


変更前のifconfig
root@OpenWrt:/etc/rc.d# ifconfig
br-lan Link encap:Ethernet HWaddr 00:18:84:**:**:**
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1850 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:138011 (134.7 KiB) TX bytes:812 (812.0 B)

eth0 Link encap:Ethernet HWaddr 00:18:84:**:**:**
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1850 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:163911 (160.0 KiB) TX bytes:1855 (1.8 KiB)
Interrupt:4 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



変更後のifconfig
root@OpenWrt:/# ifconfig
eth0 Link encap:Ethernet HWaddr 00:18:84:**:**:**
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:25 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2926 (2.8 KiB) TX bytes:1855 (1.8 KiB)
Interrupt:4 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


無事br-lanが消えました。

有線LANのインターフェースをDHCPクライアントにする
これも/etc/config/networkを書き換えるだけ。

# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
# option type bridge
option proto staticdhcp
# option ipaddr 192.168.1.1
# option netmask 255.255.255.0

有線をWAN、無線をLANにしたNATルータにする


root@OpenWrt:/etc/config# cat network
# Copyright (C) 2006 OpenWrt.org

config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0ath0 ←LAN側インターフェースにath0を指定する
option proto static
option ipaddr 192.168.??.254 ←LAN側インターフェース(無線)のIPを指定する。このアドレスがLAN側のデフォルトゲートウェイになる。
option netmask 255.255.255.0

config interface wan 
option ifname eth0 ←WAN側インターフェースにeth0を指定する
option proto dhcp




無線でWPA-PSKの暗号化を行う


root@OpenWrt:/etc/config# cat wireless
config wifi-device wifi0
option type atheros
option channel auto

# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1
option disabled 0

config wifi-iface
option device wifi0
# option network lan
option mode ap
option ssid OpenWrt
# option encryption none
option encryption 'psk'
option key 'PSKパスフレーズ'
option hidden 0 ←1にするとビーコンを飛ばさない。接続テストが終わってから1にするとよい。

テーマ : Linux
ジャンル : コンピュータ

tag : OpenVPN OpenWrt


OpenVPN on OpenWRT on FON2100E



opkgコマンドによるOpenVPNインストール

root@OpenWrt:/etc/config# opkg update
Downloading http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/Packages.gz
Connecting to downloads.openwrt.org (78.24.191.177:80)
Packages.gz 100% |*****************************************| 143k 00:00:00 ETA
Inflating http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/snapshots
root@OpenWrt:/etc/config# opkg install openvpn
Installing openvpn (2.0.9-5) to root...
Downloading http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/./openvpn_2.0.9-5_mips.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
openvpn_2.0.9-5_mips 100% |*****************************************| 149k 00:00:00 ETA
Installing kmod-tun (2.6.26.5-atheros-1) to root...
Downloading http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/./kmod-tun_2.6.26.5-atheros-1_mips.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
kmod-tun_2.6.26.5-at 100% |*****************************************| 7466 --:--:-- ETA
Installing libopenssl (0.9.8i-3) to root...
Downloading http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/./libopenssl_0.9.8i-3_mips.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
libopenssl_0.9.8i-3_ 100% |*****************************************| 483k 00:00:00 ETA
Installing zlib (1.2.3-5) to root...
Downloading http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/./zlib_1.2.3-5_mips.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
zlib_1.2.3-5_mips.ip 100% |*****************************************| 36104 00:00:00 ETA
Installing liblzo (2.03-1) to root...
Downloading http://downloads.openwrt.org/kamikaze/8.09/atheros/packages/./liblzo_2.03-1_mips.ipk
Connecting to downloads.openwrt.org (78.24.191.177:80)
liblzo_2.03-1_mips.i 100% |*****************************************| 32735 00:00:00 ETA
Configuring kmod-tun
Configuring liblzo
Configuring libopenssl
Configuring openvpn
Configuring zlib
root@OpenWrt:/etc/config#


あとは/etc/config/openvpnとiptablesの設定をいじくる。tunとathをiptablesで許可してやるとルーティングできるようになる。


tag : OpenWrt


ひかり電話(光プレミアム)でのISDNサブアドレス付の着信について

 ひかり電話でのISDNサブアドレスの挙動を調べるのに、CTUとVoIPアダプタ(AD-200SE)の間にHUBをかましてWiresharkでパケットキャプチャしてみた。
 結果はひかり電話網からVoIPアダプタへのINVITEのSIPアドレス部分が[電話番号;isub=サブアドレス@SIPサーバアドレス]になっている。

isub着信

INVITE sip:0*********;isub=12345@210.247.127.***:5060 SIP/2.0

 RFCでもISDNサブアドレスとしてisubがオプションとして定義されていてRFCに従った実装になっている模様。Draftでもisubについて言及されているものが見つかった(NTTの人が提案してたらしい)。

rfc3966(The tel URI for Telephone Numbers)
http://tools.ietf.org/html/draft-munakata-iptel-isub-type-04#page-10
http://tools.ietf.org/rfc/rfc4715.txt

 AD-200SEの新バージョン(5.52)でもISDNサブアドレス付きの着信について、やはりAD-200SEでサブアドレスを処理していてAD-200SEにレジストしているSIPクライアントには情報を渡せそうにないということを改めて確認。

 ひかり電話をISDNの置き換えとして売るのであれば、サブアドレスは欲しいところ。ビジネスホンなんかでも、内線指定して呼び出せますよね。結構重宝してるんですよ。



続きを読む

tag : ひかり電話 Asterisk


技術士二次 電気電子部門H20 一般問題 Ⅱ-2 回答例

※これは有料記事です。転載・引用は一切禁止します。
ツッコミは歓迎します。

僕が受験した時に記載した内容は確かこの程度の記述だったと思います

H20電気電子二次筆記一般問題

??2 配電線や通信線で問題となる雷サージの発生原因を2つ挙げ,その特徴を述べよ。また,近年の傾向として,雷雨日数が大きく変化していないにもかかわらず,配電線や通信線に接続された機器の雷被害が増加している。この原因と対策法について,高度情報化 社会の観点から述べよ。
続きはブロマガを購入して楽しもう!
このコンテンツはブロマガ(有料)です。
購入すると続きをお楽しみいただけます。
ブロマガって何?

技術士電気電子部門二次試験(口頭)試験体験記

※これは有料記事です。転載・引用は一切禁止します。

 技術士電気電子部門の口答試験の再現です。帰りの新幹線の中でメモった物を後に記事にしたので、正確性には欠けますがご了承ください。
続きはブロマガを購入して楽しもう!
このコンテンツはブロマガ(有料)です。
購入すると続きをお楽しみいただけます。
ブロマガって何?

技術士情報工学部門二次試験(口頭)試験体験記

※これは有料記事です。転載・引用は一切禁止します。

 技術士情報工学部門の口答試験の再現です。帰りの新幹線の中でメモった物を後に記事にしたので、正確性には欠けますがご了承ください。
続きはブロマガを購入して楽しもう!
このコンテンツはブロマガ(有料)です。
購入すると続きをお楽しみいただけます。
ブロマガって何?

WindowsMobile用SIPソフトフォンあれこれ

 WindowsMobileで使えるSIPソフトフォンを調べてみました。WindowsMobileの場合、通常のアプリから見える音声出力デバイスが背面スピーカーらしく、耳に当たる部分のスピーカーから音を出すにはいろいろ工夫がいるみたいです。ちゃんと耳にあたる部分のスピーカーから音を出してくれるソフトフォンは数が少なく、知る限りではAGEphoneとTiViが対応しています(S11HTで動作確認)。ただ、音声デバイスの制限からか、マナーモードだと音が出なかったりします。

AGEphone Mobile
 ここからダウンロードできます。ライセンスの発行を受けないと1分間の通話制限があります。UIやSIPサーバの複数登録など、機能は豊富です。国産なので日本語対応や日本国内で発売されるデバイスへの対応はピカイチです。

TiVi
 ここからダウンロードできます。ライセンスの発行を受けないと、SIPサーバの設定が保存できません。(アプリを落とすとSIPサーバの設定が消えてしまいます。)
 ダイヤルパッドがなかったり、ジッタバッファの設定など細かい設定ができません。ただし音声は背面スピーカーではなく、耳に当たる部分のスピーカーから音が出ます。

 AGEphone・TiViいずれもVoIP over 3Gだと遅延が大きすぎて(感覚的に300ms~400msぐらい?)常用には耐えないと思います。WLAN経由だともう少しマシだとは思いますが・・・。

番外編:F1100
 デバイスメーカー(富士通)がアプリまでしっかり作りこんであり、SIP/3Gを意識する必要がないつくりになっています。マナーモードにしていても当然音声もちゃんと耳に当たる部分のスピーカーから出てきます。WM機とか携帯電話としての作りはどちらも中途半端ですが、SIP対応無線コードレスと考えるのなら結構いい出来だと思います。
 WLAN経由でしか利用していませんが、コードレス電話機としては結構便利で重宝してます。

プチフリ解消!すごいツール発見!

 EEE901Xのプチフリに購入時から悩まされてきたというかあきらめていたが、FlashFireというプチフリ解消ツールを発見。プチフリがかなり解消され、ものすごく快適になった。感謝。

技術士・複数部門ホルダーへの近道!?

※これは有料記事です。転載・引用は一切禁止します。

 以前の記事で、電気電子部門(情報通信)と情報工学部門(情報ネットワーク)の違いについて記述しました。記事のとおり、科目の範囲としては似たり寄ったりな感じがします。両方合格している本人ですらよく違いがわかっていません。

 で、この電気電子部門(情報通信)と情報工学部門(情報ネットワーク)の二部門ホルダーになるための手っ取り早い方法があります。
続きはブロマガを購入して楽しもう!
このコンテンツはブロマガ(有料)です。
購入すると続きをお楽しみいただけます。
ブロマガって何?

技術士二次 情報工学部門H20 選択科目【16-4】情報ネットワーク I-2-3 回答例

問題はこちらから転載してます。SUKIYAKI塾に感謝。

大きくはずしてはいないと思うのですが、誤りや不足があれば指摘をお願いします。文字数もあまり気にしてないので過不足あるかも。



I-2-3 C 社は主要都市に支店を持ち,通信業者の専用繰により社内ネットワークを構築している。 しかし,専用線による社内ネットワークの運用は経費が高いため,インターネットを利用したVPN(Virtual Private Network)に切り替えることとした。

インターネットVPN の構築には,“IPsec VPN(Internet Protocol security VPN)"及び“SSL-VPN(Secure Socket Layer-VPN)"の2 つの方式が候補に上がり,両者について検討することとなった。

VPN への切替にあたっては,ユーザ(クライアント環境)への負担ができるだけ少ないこと, リモートアクセス(電子メールの送受信,社内Web サーバヘの接続,ファイルサーバヘのアクセス等)も可能とすることが条件である。

(1)それぞれの方式の特徴を比較して説明せよ。
(2)VPN 構築の方式を選択し,その方式について選択したキーとなる理由,及び留意すべき点について説明せよ。



(1)
【IPsecについて】
特徴
 IPsecは、暗号技術を用いて、IPパケット単位でデータの改竄防止や秘匿機能を提供するプロトコルである。これによって、暗号化をサポートしていないトランスポート層やアプリケーションを用いても、通信路の途中で通信内容を覗き見られたり改竄されることを防止できる。
 IPsecはAHによる完全性、認証機構、ESP によるデータ暗号化等のセキュリティプロトコルの他、IKE などによる鍵交換から構成されている。
 IPsecの動作モードにはパケットデータ部のみを暗号化(ないしは認証)するトランスポートモードと、ヘッダを含めたパケット全体を丸ごと「データ」として暗号化(ないしは認証)し新たなIPヘッダを付加するトンネルモードがある。(特徴はWikipediaから要約して転載)
メリット
・IPパケットをカプセリングしているため、プロトコルに制限がない。
・多数の暗号化方式に対応している。
デメリット
・UDPやESP・AHのようなパケットを利用するため、このようなパケットを通さないネットワークからの接続が困難である。
・相互接続性が低く、機器やソフトウェアの組み合わせによっては利用できなかったり不安定なケースがある。
・設定に高度な知識を要する。

【SSL-VPNについて】
※ここではブラウザのみで利用するタイプのSSL-VPNを想定して解答を作成します。
特徴
・Webブラウザで利用可能であるSSLを利用し、インターネットなどの外部ネットワークから内部ネットワークにアクセスする技術である。
メリット
・インターネット上のHTTP/HTTPSサーバにアクセスできる環境があれば接続でき、ファイヤーウォールやProxyを経由するような環境でも接続が可能である。したがって接続する場所を選ばない。
・SSLを通信経路に用いているため、盗聴や改ざんに強い。
・Webブラウザだけで利用可能であり、VPNソフトウェアのインストールが必要ないため、クライアントの環境依存が少ない。
デメリット
・通信可能なプロトコルが、SSL-VPNサーバで対応可能なプロトコルに限定される。
・IPsecに比較するとパフォーマンスが低い。

(2)
【拠点間】
拠点間接続としてはIPsecが適切である。理由下記の2点である。
1.比較的スループットが高い。
2.VPN内を流れる通信プロトコルに制限がない。
留意点:
・セキュリティの観点から、接続可能な対向機器のIPアドレスを制限する必要がある。
・ネットワークトポロジーの選定に当たってはハブ&スポークにした場合はセンター拠点に設置するVPN機器の処理能力に余裕を持たせておく必要がある。メッシュにした場合には、拠点追加等の設定変更が生じた場合、各拠点のVPN機器の設定追加が必要となる。
(トポロジーに関することなので、題意から外れるかも・・・)

【リモートアクセス】
リモートアクセス環境としてはSSL-VPNが適切である。理由は下記の2点である。
1.クライアント環境に専用ソフトウェアのインストールや、VPNを接続するための複雑な設定が不要であり、Webブラウザだけで利用が可能である。そのため、ユーザやクライアント環境への負担が少ない。
2.利用する社内サービスが限られている(電子メールの送受信,社内Web サーバヘの接続,ファイルサーバヘのアクセス等)。

留意点:
・セキュリティ確保の観点からアクセスできるクライアントの制限が必要である。しかし、利用者の環境によってはリモートアクセス元のIPアドレスが不特定となることからIPアドレスの制限では利用できる環境が限られてしまい利用者にとっては不便である。そのため、スマートカードやUSBトークンを利用して電子証明書で認証を行う方式をとる事でセキュリティを確保することができる。


 VPNについての一般的な知識のみで回答できる難易度の低い問題です。情報処理技術者試験のテクニカル系試験(ネットワーク・セキュリティ)の対策経験があれば実務経験がなくても答えられると思います。
 
 問題文中に「比較して説明せよ」とあるので、表形式にして両者を同じ目線で比較できるようにした方が模範解答としてはよいかもしれません。(模範解答を作っているのではなく、解答なので・・・)

 出題者が「SSL-VPNはブラウザのみで特定のアプリケーションを利用する」もの(例:SSL-Explorer)を想定しているのか、「HTTP(S)にIPパケットをカプセル化する」タイプのもの(例:SoftEtherとかOpenVPN)まで想定しているのかを読み取る必要があります。

 問題文中に「ユーザ(クライアント環境)への負担ができるだけ少ないこと, リモートアタセス(電子メールの送受信,社内Web サーバヘの接続,ファイルサーバヘのアクセス等)も可能とすること」とあることから、おそらくは前者を想定した回答が求められているのではないかと推測します。

 一般的には後者のものまで含めてSSL-VPNと呼ばれていますが、下手に実務経験者だとそこまで深読みし、求められている以上(あるいは題意に沿わない)の回答を行ってしまう恐れがありそうです。

 実務で求められる能力(深読み)と、試験対策で求められる能力(題意に沿って回答する)は別物と割り切る必要があるタイプの出題ですね。

テーマ : 資格取得
ジャンル : 学校・教育

tag : 技術士


Asteriskが050や0ABJ電話網に繋げなくなるかも!?

安全・安心なIPネットワーク利用等の実現に向けて
― IP電話端末等に関する技術的条件等について


 総務省がIP電話端末が具備すべき機能や認証の在り方等に関する「IP電話端末等に関する技術的条件」が検討されていて、答申を受けた結果が公表されている。(答申資料の概要

 機能として「IP電話端末は、アナログ電話相当の機能を有するインターネットプロトコル電話用設備からふくそうである旨の信号を受けた場合にあっては、その旨利用者に通知する機能を備えること。」など、「ないよりはあるほうがいいよね~。でもなくったって困んないけどさ」的な機能を持てというのは別に異論はない。ところが、「IP電話端末の技術基準適合認定の種別」と言った検討もされていて、ソフトフォンを含むIP電話端末を電気通信回線に接続する場合には認証を受ける必要が今後出てきそうなのだ。
※厳密にはこの答申ではソフトフォンの認証は0ABJの電話サービスに限られているような書きっぷりなので、050には影響ないのかも・・・。

 ということは、(技術的につながる・つながらないはさておき)Asteriskは当然認証なんか受けてないし認証を受ける主体がないはずなので、電気通信回線に直接接続することは許されなくなる、ということになる。解釈の仕方にもよるが、例えばISPの050IP電話のサーバ(これは電気通信回線に相当するはず)に直接Registができなくなってしまうのだ。ひかり電話(光プレミアム)の場合約款上はCTUまでが電気通信回線らしく、AD200のようなアダプタは認証を受けた端末扱い、すなわちその端末の下に何をぶら下げようがユーザの勝手なのでAsteriskをぶら下げるのはたぶん問題ないんだろう(自信ないけど)。確かに電気通信回線に対する悪影響を与えないため、というのはわかるんだけどさ・・・。

 パブコメしてやろうかと思ったんだけど、すでにパブコメ終わってんのね。残念。

tag : 050 Asterisk 通信行政


GA-MA78GM-S2Hのノースブリッジヒートシンクを換装する。

気温が上がってきてノースブリッジのヒートシンクが触れないぐらい熱くなりだしたのでヒートシンクをAINEXのファンつきCB-3845BLに交換した。


マザボのデザイン的にPCIeのカードと干渉してしまう。

交換前は「指を押し当てて我慢しきれない感じ」が「指を押し当ててあったかい感じ」まで変わったので多分55℃から45℃程度に落ちたのではないかなと思う。

ただ、BCM5751の方がヒートシンクつけても触れないぐらい熱いのでこっちのほうが問題かも。Intel Pro1000ptはしっかりしたヒートシンクがついているのか、発熱量が少ないのかあまり気にならない。

ヒートシンクをはずしたところ。
はずしたところ

取り付けたところ。
取り付け後1

取り付け後2
取り付け後3
取り付け後4

AD-200SE、Ver5.52でも同一IPから複数REGISTできず

AD-200SEはファームウェアバージョン5.52にアップデートしても、やっぱり同一IPアドレスからのRegistはできませんでした。

AsteriskのCLI
Asteriskからは内線3と内線5がRegist出来ているように見えるんですが、

AD200SE画面
AD-200SEの管理画面から見ると、内線5が未登録になってしまいました。

同一IPから複数Registができるようにならないと、追加番号を使って発信者番号を使い分けたり、2ch同時通話ができないのでなんとかして欲しいところです。


テーマ : Linux
ジャンル : コンピュータ


Opensolaris2009.6でxVMを動かす

無償版のESX4iがRCLIでいじれなくなってしまったのでxVMを試してみようと思った。
ここを参考に、xVMをインストールしてみる。


$ su -
Password:
Sun Microsystems Inc. SunOS 5.11 snv_111b November 2008
root@zfs:~# beadm create -a -d xvm xvm
root@zfs:~# beadm mount xvm /tmp/xvm-be
root@zfs:~# pkg -R /tmp/xvm-be install SUNWvirt-manager SUNWxvm SUNWvdisk SUNWvncviewer
DOWNLOAD PKGS FILES XFER (MB)
Completed 6/6 637/637 8.94/8.94

PHASE ACTIONS
Install Phase 889/889
root@zfs:~# beadm umount xvm
root@zfs:~# awk '
> /^title/ { xvm=0; }
> /^title.xvm$/ { xvm=1; }
> /^(splashimage|foreground|background)/ {
> if (xvm == 1) next
> }
> /^kernel\$/ {
> if (xvm == 1) {
> print("kernel\$ /boot/\$ISADIR/xen.gz")
> sub("^kernel\\$", "module$")
> gsub("console=graphics", "console=text")
> gsub("i86pc", "i86xpv")
> $2=$2 " " $2
> }
> }
> { print }' /rpool/boot/grub/menu.lst >/var/tmp/menu.lst.xvm
awk: コマンドライン:8: 警告: エスケープシーケンス `\$' は `$' と同等に扱われます。
root@zfs:~# cat /var/tmp/menu.lst.xvm
splashimage /boot/grub/splash.xpm.gz
background 215ECA
timeout 3
default 1
#---------- ADDED BY BOOTADM - DO NOT EDIT ----------
title OpenSolaris 2009.06
findroot (pool_rpool,0,a)
bootfs rpool/ROOT/opensolaris
splashimage /boot/solaris.xpm
foreground d25f00
background 115d93
kernel$ /platform/i86pc/kernel/$ISADIR/unix -B $ZFS-BOOTFS,console=graphics
module$ /platform/i86pc/$ISADIR/boot_archive
#---------------------END BOOTADM--------------------
title xvm
findroot (pool_rpool,0,a)
bootfs rpool/ROOT/xvm
kernel$ /boot/$ISADIR/xen.gz
module$ /platform/i86xpv/kernel/$ISADIR/unix /platform/i86xpv/kernel/$ISADIR/unix -B $ZFS-BOOTFS,console=text
module$ /platform/i86pc/$ISADIR/boot_archive
#============ End of LIBBE entry =============
root@zfs:~# cp /rpool/boot/grub/menu.lst /rpool/boot/grub/menu.lst.org
root@zfs:~# mv /var/tmp/menu.lst.xvm /rpool/boot/grub/menu.lst
root@zfs:~# reboot


リブートしたら、なぜか一度シングルユーザモードになってしまった。再度リブートしたら無事起動。


$ su -
Password:
Sun Microsystems Inc. SunOS 5.11 snv_111b November 2008
root@zfs:~# xm list
Error: Unable to connect to xend: No such file or directory. Is xend running?
root@zfs:~# svcadm enable -r xvm/virtd ; svcadm enable -r xvm/domains
svcadm: svc:/system/filesystem/local depends on svc:/network/physical, which has multiple instances.
svcadm: svc:/system/filesystem/local depends on svc:/network/physical, which has multiple instances.
root@zfs:~# xm list
Name ID Mem VCPUs State Time(s)
Domain-0 0 7674 2 r----- 55.7
root@zfs:~#


DOM0が見えたので多分大丈夫なんだろう。Xenをいじるのは初めてなので、これから勉強する予定。

tag : OpenSolaris xVM



カテゴリ


最新記事

月別アーカイブ

最新コメント

最新トラックバック









上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。